Tuesday, September 01, 2015

Fixing a Kenmore Vacuum That Won't Turn Off

One day, after using my old Kenmore Canister Vacuum cleaner, its motor would not turn off, even though I flipped the switch to the off position. The only way to turn off the vacuum in this state is to pull the plug, which causes sparking at the outlet because the motor is a big inductor.

This vacuum has the on-off switch built into the hose handle so that it is easy to turn on and off. This vacuum is actually made by Panasonic, and has been super reliable for the 10+ years that it has been in my family. This repair guide should apply to many vacuums made by Panasonic, and other manufacturers.

After some debugging, I found that the problem is a high amperage relay inside the vacuum canister that welds itself together from repeated on-off cycles. This actually happened twice to our vacuum. The first time this happened in 2007, I replaced the relay with an Omron 25A contact / 120VAC coil relay that I found on Mouser; it fit perfectly, and is the relay pictured below. Unfortunately, Omron discontinued that model of relay, but I bet something like this relay on Amazon would work just fine if you use the normally-open terminals.

Eight years later in 2015, the relay got stuck again; this time I decided to service the relay instead of replace it. After opening up the relay, I confirmed that the contacts welded themselves together from repeatedly turning the vacuum on and off, which causes arcing and enough heat to eventually melt the contacts together.

To repair the relay, I used a screwdriver to pry the contacts apart, and then used sand paper to sand off the carbon build up on the contacts and to remove the melted bits of the contact. After the contacts were clean and shiny, I put the relay back together and tested it out. We've been using the vacuum for a few months since then, and the repair has been holding up. It might not hold up as long as a brand new relay, but it should hold up for a while, and I can just repair the relay again if it melts again.

Here are the steps for the repair:

FIRST UNPLUG THE VACUUM!

Then, remove the hose from the canister:
Pull up on the HEPA filter cover to remove it and expose the case screws:
Remove the HEPA filter:
Remove the screws under the HEPA cover:
Open the bag compartment:
Remove the screws holding the blue case half to the grey case half:
Here's what you'll find inside the vacuum, the motor, the wire reel, and the relay (in my case, beside the motor):
Take a look at how the motor is oriented. You'll need to orient it the same way for the motor to fit into its spot:
Lift out the motor and move it aside, leaving the wires connected. You can now see the relay (the small box will all the wires connected to it):
Unscrew the relay:
Pop open both sides of the relay with something thin and small, like a small flat screw driver:
Slide the cover off:
Here's the contacts inside the relay. Noticed that the contacts are welded together. This is why the vacuum didn't turn off!
Here's the relay after separating the contacts:
Next, I sanded the contacts to remove the melted metal, and shine up the contact area:
At this point, I reassembled the vacuum which is the reverse of disassembly. The vacuum has been working great ever since!

4 comments:

MB Gizmo said...

Fantastic illustration & photos. My 2 year old Panasonic won't turn on. Would like to know if this is a relay issue.

MB Gizmo said...

My 2 year old Panasonic won't turn on. Do you think this is a relay issue?

Alex said...

It could be the relay. Sometimes they fail the opposite way; the contacts get dirty and no longer conduct electricity. It could also be the switch, the 360deg coupling, or the internal fuse (mine was covered with black shrink wrap, but it was a regular cylindrical glass fuse.

Alexander Riccio said...

Nice debugging :)